1. 程式人生 > >杭電ACM-1050 Moving Tables

杭電ACM-1050 Moving Tables

                                            Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43080    Accepted Submission(s): 14081


 

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10

20

30

題目大意是給N組數,每組數代表的是從a房間搬桌子到b房間,求搬完N組需要的最短時間,

注意,不管從哪裡搬到哪裡都只會花費10分鐘。

(開始沒看清題,先看的樣例1,還以為是1分鐘一個房間,自我迷失了半天)

解題思路:

有兩種情況:

第一種是所有的路線不重疊,時間就是10分鐘。

第二種情況是路線交叉,那麼就需要兩次或者更多次來完成搬桌子,需要的時間就是  次數 乘以  10分鐘。

具體AC程式碼如下:

 

//#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
//經過本房間次數最多的乘以10分鐘就是用的最短時間。
using namespace std;
int main()
{
    int t,k;
    cin>>t;
    for(k=1;k<=t;k++)
    {
        int n,i,j,count[403];
        memset(count,0,sizeof(count));  //陣列初始化        
        cin>>n;
        int a,b,temp;
        for(j=1;j<=n;j++)
        {
            cin>>a>>b;
            a=(a-1)/2;   //走廊數            		 
            b=(b-1)/2;   //走廊數            
         if(a>b)             //將資料寫成從小到大排列            
	     	{
                temp=a;
                a=b;
                b=temp;
            }           
            for(i=a;i<=b;i++)   
                            //也就是說每經過某個數的位置時這個位置的次數加一                
            count[i]++;
        }
        int max=count[1];      //初始化     
            for(j=1;j<=200;j++)
            if(max<count[j])    
                            //選取其中最大數值乘10,即當前所用最短時間。                                    
             max=count[j];
            cout<<max*10<<endl;
    }
    return 0;
}