1. 程式人生 > >PAT 1090 Highest Price in Supply Chain (25 分)

PAT 1090 Highest Price in Supply Chain (25 分)

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.


Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤ 1 0 5 10^5

), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S
i S_i
is the index of the supplier for the i-th member. S r o o t S_{root} for the root supplier is defined to be −1. All the numbers in a line are separated by a space.


Output Specification:
For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1 0 10 10^{10} .

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2




解析

在這裡插入圖片描述
和A1079一樣,都是樹的遍歷。
Then the next line contains N numbers, each number S i S_i is the index of the supplier for the i-th member
題目這句話是和A1079不一樣的,第二行的數字代表 S i S_i i i 供應。所以父親和兒子的關係要搞清楚。
求樹的深度,用DFS或BFS都行。
當然:還是用靜態實現樹。
Code

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<queue>
#include<string>
#include<cmath>
using namespace std;
const int maxn = 100001;
struct node {
	int layer;
	vector<int> child;
	node() :layer(0) { ; }
}Node[maxn];
int BFS(int root) {
	int maxdep = 1;
	queue<int> Q;
	Q.push(root);
	Node[root].layer = 1;
	while (!Q.empty()) {
		int temp = Q.front();
		Q.pop();
		maxdep = Node[temp].layer;
		for (auto x : Node[temp].child) {
			Q.push(x);
			Node[x].layer = Node[temp].layer + 1;
		}
	}
	return maxdep;
}
int main()
{
	int N,root,father;
	double P, r;
	scanf("%d %lf %lf", &N, &P, &r);
	for (int i = 0; i < N; i++) {
		scanf("%d", &father);
		if (father == -1) 
			root = i;
		else 
			Node[father].child.push_back(i);
	}
	int result = BFS(root), count = 0;
	count = count_if(begin(Node), end(Node), [result](node a) {
											return a.layer == result; });
	printf("%.2f %d", P*pow((1 + r / 100), result - 1),count);
}