1. 程式人生 > >1007 Maximum Subsequence Sum (25 分)

1007 Maximum Subsequence Sum (25 分)

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

題目中要求求解和最大的連續子序列,並且如果序列中所有數字都為負數,則和為0,然後輸出子序列的和以及子序列區間左邊節點右邊節點位置上的數字

直接使用字首和解決即可,當前綴和小於0時,直接將字首和置為0,然後重新標記左邊節點位置,因為字首和已經為0了,那麼加上前面已經會使後面越來越小,如果存在比當前最大值大的數值,則更新最大數值,左邊節點,右邊節點。

當我們求解出最大子序列和為ans初值-1時,我們即可確定序列中所有數字都為負數

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <cmath>
#define INF 0x3f3f3f3f

using namespace std;
typedef long long ll;
const int mod = 1e9+7;
const int maxn = 1e4+1000;
int n,a[maxn];
int temp;

int main()
{
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",a+i);

    int _min_pos = 0,left_pos = 0,right_pos = 0,ans = -1;
   temp = 0;
    for(int i = 0;i < n;i ++)
    {
        temp += a[i];
        if(temp < 0)
            temp = 0 ,_min_pos = i+1;
        else if(temp  > ans)
            ans = temp,right_pos = i,left_pos = _min_pos;
    }
    if(ans < 0)
        printf("0 %d %d\n",a[0],a[n-1]);
    else
        printf("%d %d %d\n",ans,a[left_pos],a[right_pos]);

}

 

參考部落格

https://blog.csdn.net/liuchuo/article/details/52144554