1. 程式人生 > >[區間DP] 受兩邊數影響刪除數 POJ1651

[區間DP] 受兩邊數影響刪除數 POJ1651

Multiplication Puzzle

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13686   Accepted: 8395

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion

 

 

#include <iostream>
#include <cstdio>
#include <string> 
#include <cstring>
#define ll long long
using namespace std;
const int inf = 0x3f3f3f3f;
const ll mod = 1e9 + 7;
const int mn = 110;

int a[mn];
int dp[mn][mn];
int main()
{
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++)
		cin >> a[i];
	
	for (int i = 1; i <= n - 2; i++)		// 兩端保留 中間數刪除
		dp[i][i + 2] = a[i] * a[i + 1] * a[i + 2];
	
	for (int l = 4; l <= n; l++)
	{
		for (int i = 1; i <= n && i + l - 1 <= n; i++)
		{
			int j = i + l - 1;
			dp[i][j] = inf;
			
			for (int k = i + 1; k <= j - 1; k++)	// i, k, j 保留時, 刪除 k
				dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j] + a[i] * a[k] * a[j]);
		}
	}
	cout << dp[1][n] << endl;
	
	return 0;
}