1. 程式人生 > >Party at Hali-Bula POJ - 3342(樹形dp)

Party at Hali-Bula POJ - 3342(樹形dp)

Dear Contestant,

I’m going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I’ve attached the list of employees and the organizational hierarchy of BCM.

Best,
–Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input
6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0
Sample Output
4 Yes
1 No

這個題目和那個沒有上司的舞會很相似,如果不是需要判斷有沒有固定的解,直接複製過來就好了,但是要判斷是不是解的個數相同。這就需要好好判斷一下了。dfs跑完以後,就需要每個點去遍歷一下。如果當前點上司不去大於上司去,就要遍歷一下它的子節點看看是否相同。
程式碼如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<cmath>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;

map<string,int>mp;
vector<int>vec[205];
int dp[205][2];
int n;
char a[205],b[205];
int cnt;
char str[205][105];

void dfs(int top)
{
	for(int i=0;i<vec[top].size();i++)
	{
		int v=vec[top][i];
		dfs(v);
		dp[top][1]+=dp[v][0];
		dp[top][0]+=max(dp[v][1],dp[v][0]);
	}
}

int main()
{
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<n;i++)
		{
			dp[i][0]=0;
			dp[i][1]=1;
			vec[i].clear();
		}
		mp.clear();
		cnt=0;
		cin>>a;
		mp[a]=cnt++;
		for(int i=1;i<n;i++)
		{
			cin>>a>>b;
			/*if(!mp[a]) mp[a]=cnt++;
			if(!mp[b]) mp[b]=cnt++;
			vec[mp[b]].push_back(mp[a]);*/
			if(mp.find(a)==mp.end()) mp[a]=cnt++;//很重要
            if(mp.find(b)==mp.end()) mp[b]=cnt++;
            vec[mp[b]].push_back(mp[a]);
		}
		dfs(0);
		int flag=1;
		for(int i=0;i<n;i++)
		{
			if(dp[i][0]>dp[i][1])
            {
                for(int j=0; j<vec[i].size(); j++)
                {
                    int v=vec[i][j];
                    if(dp[v][0]==dp[v][1])
                    {
                        flag=0;
                        break;
                    }
                }
            }
            if(flag==0)
            break;
		}
		if(flag==0||dp[0][0]==dp[0][1])
		printf("%d No\n",max(dp[0][0],dp[0][1]));
		else printf("%d Yes\n",max(dp[0][1],dp[0][0]));
	}
}

努力加油a啊,(o)/~