1. 程式人生 > >How Many Maos Does the Guanxi Worth(去掉某一點及其所有的邊)(n次Dijkstra求最短路最大值)

How Many Maos Does the Guanxi Worth(去掉某一點及其所有的邊)(n次Dijkstra求最短路最大值)

How Many Maos Does the Guanxi Worth

“Guanxi” is a very important word in Chinese. It kind of means “relationship” or “contact”. Guanxi can be based on friendship, but also can be built on money. So Chinese often say “I don’t have one mao (0.1 RMB) guanxi with you.” or “The guanxi between them is naked money guanxi.” It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu’s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A “big money” means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net – it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help … If the request finally reaches the schoolmaster, Boss Liu’s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu’s plan. All you can do is to persuade ONE person in Boss Liu’s guanxi net to reject any request. This person can be any one, but can’t be Boss Liu or the schoolmaster. If you can’t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu’s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu’s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It’s guaranteed that Boss Liu’s request can reach the schoolmaster if you do not try to undermine his plan.
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print “Inf” instead.
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
Sample Output
50
Inf

題目大意:劉老闆向通過他的關係網來賄賂朋友,通過朋友賄賂校長,賄賂成功後他兒子就能上重點學校了。善良的你要阻止邪惡的劉老闆,你能說服劉老闆的朋友們中的一個人,當然你不能說服校長和劉老闆本人,如果能說服一個人使得劉老闆無法聯絡到校長,那麼就輸出Inf,否則的話,你說服其中一個人後,使得劉老闆在他最短捷徑中損失最大,即劉老闆很精明,他知道每條最短路徑,你需要破壞一個人,然後使得他花費血本最大。(劉老闆編號為1,校長編號為n)

解題思路:列舉去掉每個中間人的所有情況,然後更新ans使得ans在所有最短路徑中值最大。

原文:https://blog.csdn.net/zugofn/article/details/52123294

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=35;
const int Inf=999999999;
int G[maxn][maxn],dis[maxn],n,m;
bool vis[maxn],flag=false;
void dj(){
	for(int i=1;i<=n;i++)
	dis[i]=G[1][i];
	vis[1]=true;
	for(int k=1;k<n;k++){
		int mint=Inf,u=0;
		for(int i=1;i<=n;i++){      //找離點1最近的點 
			if(!vis[i]&&dis[i]<mint){
				mint=dis[i];
				u=i;
			}
		}
		if(u==0) return ;
		vis[u]=true;
		for(int i=1;i<=n;i++){
			if(dis[i]>dis[u]+G[u][i])
			dis[i]=dis[u]+G[u][i];
		} 
	}			
}
int main(){
	while(scanf("%d%d",&n,&m)){
		if(n==0&&m==0) break;
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				if(i==j) G[i][j]=0;
				else G[i][j]=Inf;
			}
		}
		for(int i=1;i<=m;i++){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
				G[a][b]=G[b][a]=c;//雙向聯通
		}
		int ans=-1;
		for(int i=2;i<n;i++){//列舉某個人被說服 
			memset(vis,0,sizeof(vis));
			vis[i]=true;//被說服後這個點就不能被訪問
			dj();
			if(ans<dis[n]) ans=dis[n];
		}
		if(ans==Inf) printf("Inf\n");
		else printf("%d\n",ans);
	}
	return 0;
}