1. 程式人生 > >Til the Cows Come Home(單源最短路)(Dijstra模板題)

Til the Cows Come Home(單源最短路)(Dijstra模板題)

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

題意:找從1到n的最短距離。
注意:雙向聯通
單源最短路,Dijkstra模板題

#include<cstdio>
#include<vector>
#include<queue> 
#include<cstring>
using namespace std;
const int Inf=999999999; 
struct node{
	int v,w;//後繼結點與權值 
	node(){}
	node(int vv,int ww){
		v=vv;
		w=ww;
	} 	
};
struct Node{
	int u,w;//前驅結點與權值
    Node(){}
	Node(int uu,int ww) {
		u=uu;
		w=ww;
	}
	bool operator<(const Node other)const{
	return w>other.w;
	}
};
const int N=1005;
int book[N],dis[N];
int t,n;
vector<node> G[N];
void Dijkstra(){
	priority_queue<Node> p;
	memset(book,0,sizeof(book));
	for(int i=1;i<=n;i++)
	dis[i]=Inf;
	dis[1]=0;
	p.push(Node(1,dis[1]));
	while(!p.empty()){
		Node temp=p.top();
		p.pop();
		int u=temp.u;
		if(book[u]) continue;
		book[u]=1;
		for(int i=0;i<G[u].size();i++){
			node tv=G[u][i];
			int v=tv.v;
			int w=tv.w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				p.push(Node(v,dis[v]));
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main(){
	while(~scanf("%d%d",&t,&n)){
		int u,v,w;
		while(t--){
		scanf("%d%d%d",&u,&v,&w);
		G[u].push_back(node(v,w));//雙向聯通
		G[v].push_back(node(u,w));
		}
		Dijkstra();	
	}
	return 0;
}