1. 程式人生 > >POJ——1273 Drainage Ditches (最大流,ekmaxflow)

POJ——1273 Drainage Ditches (最大流,ekmaxflow)

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

題意:給出n個河流(挖的溝),m個點(溝與溝的交叉點),以及每個河流的流量,求從1到m點的最大流量。1是池塘,m是小溪。

題解:最大流模板題,詳細見程式碼。

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int inf = 0x3f3f3f3f;
const int MAX = 500;
int n,m;
int map[MAX][MAX],flow[MAX][MAX];
int p[MAX],a[MAX];
int ekmaxflow(int s,int t){
    int sum=0;
    int i;
    queue<int>q;
    memset(flow,0,sizeof(flow));
    while(true){//沒有其他增廣路線時停止
        memset(a,0,sizeof(a));//記住殘餘水量
        a[s]=inf;
        q.push(s);
        while(!q.empty()){
            int u=q.front();
            q.pop();
            for(i=2;i<=m;i++){
                if(!a[i]&&map[u][i]>flow[u][i]){
                    p[i]=u;
                    q.push(i);
                    a[i]=a[u]<map[u][i]-flow[u][i]?a[u]:map[u][i]-flow[u][i];
                }
            }
        }
        if(!a[t])////為 0 時離開
        break;
        for(i=t;i!=s;i=p[i]){
            flow[p[i]][i]+=a[t];
            flow[i][p[i]]-=a[t];
    	}
        sum=sum+a[t];
    }
    return sum;
}
int main(){
    while(cin >> n >> m){
        memset(map,0,sizeof(map));
        memset(p,0,sizeof(p));//記住每個點的父親是哪兒位
        while(n--){
        	int a,b,c;
            cin >> a >> b >> c;
            map[a][b]=map[a][b]+c;//存兩個點之間的流量
        }
        int maxx=ekmaxflow(1,m);
        cout << maxx <<endl;
	}
	return 0;
}

 

小菜雞的我不是很懂,不懂樣例為什麼是50,講真,板子挺猛,這題,孃的,呵呵呵~~~