1. 程式人生 > >HDU——3577 Fast Arrangement (線段樹+區間更新+最值查詢)

HDU——3577 Fast Arrangement (線段樹+區間更新+最值查詢)

Chinese always have the railway tickets problem because of its' huge amount of passangers and stations. Now goverment need you to develop a new tickets query system. 
One train can just take k passangers. And each passanger can just buy one ticket from station a to station b. Each train cannot take more passangers any time. The one who buy the ticket earlier which can be sold will always get the ticket. 

Input

The input contains servel test cases. The first line is the case number. In each test case: 
The first line contains just one number k( 1 ≤ k ≤ 1000 ) and Q( 1 ≤ Q ≤ 100000 ) 
The following lines, each line contains two integers a and b, ( 1 ≤ a < b ≤ 1000000 ), indicate a query. 
Huge Input, scanf recommanded.

Output

For each test case, output three lines: 
Output the case number in the first line. 
If the ith query can be satisfied, output i. i starting from 1. output an blank-space after each number. 
Output a blank line after each test case.

Sample Input

1
3 6
1 6
1 6
3 4
1 5
1 2
2 4

Sample Output

Case 1:
1 2 3 5 

自己的第一個線段樹,不是很懂,我會努力的,加油!!

題意:有一個火車同時最多有k個人,然後有q個人買票,先買先得,問:哪些人能買到。 

題解:線段樹+區間更新+最值查詢 模板題,詳細見程式碼。

#include <iostream>
using namespace std;
const int MAX = 1e6+1;
struct hh{
	int l,r,maxx,lazy;//lazy標記不太懂,嚶嚶嚶~~~
}tree[MAX<<2];
int k,q,l,r;
//id表示第幾個幾點
void buildtree(int id,int l,int r){//建樹
	tree[id].l=l;
	tree[id].r=r;
	tree[id].maxx=0;
	tree[id].lazy=0;
	if(l!=r){
		int mid = (l+r)>>1;
		buildtree(id<<1,l,mid);
		buildtree(id<<1|1,mid+1,r);
	}
}
void pushdown(int id){//向下更新
	if(!tree[id].lazy) return;
	tree[id<<1].maxx+=tree[id].lazy;
	tree[id<<1].lazy+=tree[id].lazy;
	tree[id<<1|1].maxx+=tree[id].lazy;
	tree[id<<1|1].lazy+=tree[id].lazy;
	tree[id].lazy=0;
}
void pushup(int id){//向上更新
	tree[id].maxx=max(tree[id<<1].maxx,tree[id<<1|1].maxx);
}
void update(int id,int l,int r){//更新
	if(tree[id].l==l&&tree[id].r==r){
		tree[id].maxx++;
		tree[id].lazy++;
		return;
	}
	pushdown(id);
	int mid=(tree[id].l+tree[id].r)/2;
	if(r<=mid) update(id<<1,l,r);
	else if(l>mid) update(id<<1|1,l,r);
	else {
		update(id<<1,l,mid);
		update(id<<1|1,mid+1,r);
	}
	pushup(id);
}
int query(int id,int l,int r){//查詢
	if(tree[id].l==l&&tree[id].r==r){
		return tree[id].maxx;
	}
	pushdown(id);
	int mid = (tree[id].l+tree[id].r)>>1;
	if(r<=mid) return query(id<<1,l,r);
	else if(l>mid) return query(id<<1|1,l,r);
	else return max(query(id<<1,l,mid),query(id<<1|1,mid+1,r));
}
int main(){
	int t;
	int cas=1;
	cin >> t;
	while(t--){
		cin >> k >> q;
		buildtree(1,1,MAX);
		cout << "Case " << cas++ << ":" << endl;
		for (int i = 1; i <= q;i++){
			cin >> l >> r;
			r--;
			if(query(1,l,r) < k){
				update(1,l,r);
				cout << i << " ";
			}
		}
		cout << endl << endl;
	}
	return 0;
}