1. 程式人生 > >Choose the best route

Choose the best route

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

這道題是最短路啊,但是你需要從終點向起點走,但是呢路程是單向的,並且你要格外注意這件事,我頭鐵錯了好多次啊,但是也要努力啊!

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<stack>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int a[1111][1111],dis[1111];
bool book[1111];
int n,m,en;
int main()
{
    while(~scanf("%d%d%d",&n,&m,&en))
    {
        int i,j,k,t1,t2,t3,u,v;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
                if(i==j)
                a[i][j]=0;
            else
                a[i][j]=inf;

        }
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            if(t3<a[t2][t1])
            {
                a[t2][t1]=t3;
           
            }
        }
        for(i=1;i<=n;i++)
        {
            book[i]=0;
            dis[i]=a[en][i];
        }
        book[en]=1;
        int minn;
        for(i=1;i<=n-1;i++)
        {
            minn=inf;
            for(j=1;j<=n;j++)
            {
                if(!book[j]&&dis[j]<minn)
                {
                    minn=dis[j];
                    u=j;
                }

            }
            book[u]=1;
            for(v=1;v<=n;v++)
            {
                if(!book[v]&&a[u][v]!=inf&&dis[v]>dis[u]+a[u][v])
                    dis[v]=dis[u]+a[u][v];
            }
        }
        int a,x,ans=inf;
        scanf("%d",&a);
        for(i=1;i<=a;i++)
        {
            scanf("%d",&x);
            if(ans>dis[x])
                ans=dis[x];
        }
        if(ans!=inf)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
    return 0;
}