1. 程式人生 > >HDU 2053 - Switch Game (開燈問題)

HDU 2053 - Switch Game (開燈問題)

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21842    Accepted Submission(s): 13386


 

Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

 

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

 

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

 

Sample Input

1

5

Sample Output

1

0

Hint

hint Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

題意:

      n盞開始為關閉的燈,經過n次操作,問第n盞燈最後的狀態。

思路:

     一開始想著模擬,但是又一想一定會超時,然後就發現第n盞燈的開關和它約數的個數有關,約數的個數為偶數是燈為關閉的,約束的個數為奇數燈為開的。

程式碼:

#include<stdio.h>
#include<math.h>
int main()
{
	int i,n,c;
	int a[100000];
	while(scanf("%d",&n)!=EOF)
	{
		c=0;
		for(i=1;i<=n;i++)
		{
			if(n%i==0)
				c++;
		}
		if(c%2==0)
			printf("0\n");
		else
			printf("1\n");
	}
	return 0;
}