1. 程式人生 > >HDU3336——Count the string【擴充套件KMP】

HDU3336——Count the string【擴充套件KMP】

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14735    Accepted Submission(s): 6734


 

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1 4 abab

 

 

Sample Output

 

6

 

 

Author

[email protected]

 

Source和就是

HDOJ Monthly Contest – 2010.03.06

 

題目大意:給你一個字串,問這個字串的每一個字首在這個字串中出現的次數之和。

大致思路:看到處理字串的字首的問題我們可以是這去聯想擴充套件KMP演算法,在擴充套件KMP演算法中next[i]表示在字串T中從T[i]~T[len - 1]與字串T的最長公共字首長度。然後next[I]的  和就是我們要求解的答案。

#include <bits/stdc++.h>
#define mod 10007
using namespace std;

typedef long long ll;
const int MAXN = 2000100;
char s[MAXN];
ll NextVal[MAXN];

void GetNextVal(char *str){
	int i = 0, j, pos, len = strlen(str);
	NextVal[0] = len;
	while(str[i] == str[i + 1] && i + 1 < len) i++;
	NextVal[1] = i;
	pos = 1;
	for(i = 2; i < len; i++){
		if(NextVal[i - pos] + i < NextVal[pos] + pos) NextVal[i] = NextVal[i - pos];
		else{
			j = NextVal[pos] + pos - i;
			if(j < 0) j = 0;
			while(i + j < len && str[j] == str[j + i]) j++;
			NextVal[i] = j;
			pos = i; 
		}
	}
}

int main(int argc, char const *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		scanf("%s",s);
		GetNextVal(s);
		ll sum = 0;
		for(ll i = 0; i < n; i++){
			sum = (sum + NextVal[i]) % mod;
		}
		printf("%lld\n",sum);
	}
	return 0;
}