1. 程式人生 > >POJ 1164 The Castle (深搜)

POJ 1164 The Castle (深搜)

The Castle

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8241   Accepted: 4648

Description

     1   2   3   4   5   6   7  

   #############################

 1 #   |   #   |   #   |   |   #

   #####---#####---#---#####---#

 2 #   #   |   #   #   #   #   #

   #---#####---#####---#####---#

 3 #   |   |   #   #   #   #   #

   #---#########---#####---#---#

 4 #   #   |   |   |   |   #   #

   #############################

(Figure 1)



#  = Wall   

|  = No wall

-  = No wall


Figure 1 shows the map of a castle.Write a program that calculates 
1. how many rooms the castle has 
2. how big the largest room is 
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

Input

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

大概題意:

就是給定一個m*n的矩陣,有很多的空間,有的是由牆隔開的,現在要找到一共有多少個房間,以及最大的房間是多大?並把它兩打印出來。
具體思路:
第一:定義一個儲存矩陣資料的二維陣列,以及用來做標記的二維陣列
第二:西是1,北是2,東是4,南是8,因此要判斷是否能通過,只要對date中的資料依次和1,2,4,8相與,就知道了是否能過通行。
第三:就是一個深搜,也就是我們所說的完美的遞迴呼叫。

具體程式碼實現如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int r,c,roomarea,roomnum = 0,maxroom = 0;
int room[60][60],visit[60][60];
void dfs(int i,int j)
{
    if(visit[i][j])
        return;
    roomarea++;
    visit[i][j] = roomnum;
    if(!(room[i][j] & 1))
        dfs(i,j - 1);
    if(!(room[i][j] & 2))
        dfs(i - 1,j);
    if(!(room[i][j] & 4))
        dfs(i,j + 1);
    if(!(room[i][j] & 8))
        dfs(i + 1,j);
}
int main()
{
    scanf("%d %d",&r,&c);
    for(int i = 1;i <= r; i++)
    {
        for(int j = 1;j <= c; j++)
        {
            scanf("%d",&room[i][j]);
        }
    }
    memset(visit,0,sizeof(visit));
    for(int i = 1;i <= r; i++)
    {
        for(int j = 1;j <= c; j++)
        {
            if(!visit[i][j])
            {
                roomnum++;
                roomarea = 0;
                dfs(i,j);
                maxroom = max(maxroom,roomarea);
            }
        }
    }
    cout << roomnum << endl << maxroom;
    return 0;
}