1. 程式人生 > >HDU1179 Ollivanders: Makers of Fine Wands since 382 BC.【二分圖 最大匹配】

HDU1179 Ollivanders: Makers of Fine Wands since 382 BC.【二分圖 最大匹配】

Ollivanders: Makers of Fine Wands since 382 BC.

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2464    Accepted Submission(s): 1387


 

Problem Description

In Diagon Alley ,there is only one Wand-seller,peeling gold letters over the door read Ollivanders: Makers of Fine Wands since 382 BC.A single wand lay on a faded purple cushion in the dusty window. 
A tinkling bell rang somewhere in the depths of the shop as they stepped inside.It was a tiny place,empty execpt for a single spindly chair which Hagrid sat on to wait.Harry felt strangely as though he had entered a very strict library;he swallowd a log of new questions which had just occurred to him and looked instead at the thousands of narrow boxes piled neatly right up to the ceiling.For some reason,the back of his neck prickled.The very dust and silence in here seemed to tingle with some secret magic. 
'Good afternoon,'said a soft voice.Harry jumped.Hagrid must have jumped,too,because there was a loud crunching noise and he got quickly off the spindly chair. 
An old man was standing before them, his wide pale eyes shining like moons through the gloom of the shop. 
'Hello,' said Harry awkwardly. 
'Ah yes,' said the man. 'Yes,yes. I thought I'd be seeing you soon,Harry Potter.'It wasn't a question.You have your mother's eyes. It seems only yesterday she was in here herself,buying her first wand. Ten and a quarter inches long, swishy, made of willow. Nice wand for charm work.' 
Mor Ollivander moved closer to Harry.Harry wished he would blink.Those sivery eyes were a bit creepy. 
'Your father, on the other hand, favoured a mahogany wand.Eleven inches.Pliable.A little more power and excellent for transfiguration.Well ,I say your father favoured it - it's really the wand that choosed the wizard, of cource.' 

Yes, some wands fit some wizards ,as we all know.But what Harry doesn't know is Ollivander have met a big trouble.That's more than twenty years ago,When Harry's father James Potter was still a student in Hogwarts.He went Diagon Alley to buy new books,passing by Ollivander's shop.Ollivander was crazy for a problem:He was too busy to choose most suitable wand for every wizard.Even more,there are too many customer that day.Though Ollivader knew every wand's favourite,he could not choose as many wizards as possible to get the wands. So James Potter,a very clever man ,gave him a magic disk with your program ,to help him sell wands as many as possible. 

Please notice: one wand can only be sold to one wizard, and one wizard can only buy one wand,too. 

Input

There are several cases. For each case, there is two integers N and M in the first line,which mean there is N wizards and M wands(0 < N <= M <= 100).
Then M lines contain the choices of each wand.The first integer in i+1th line is Ki,and after these there are Ki integers Bi,j which are the wizards who fit that wand. (0<=Ki<=N,1<=Bi,j<=N)

Output

Only one integer,shows how many wands Ollivander can sell.

Sample Input

3 4
3 1 2 3
1 1
1 1
0

Sample Output

2

Hint

Hint Wand 1 fits everyone, Wand 2,3 only fit the first wizard,and Wand 4 does not fit anyone.So Ollivanders can sell two wands: sell Wand 1 to Wizard 2 and Wand 2 to Wizard 1,or sell Wand 1 to Wizard 3 and Wand 3 to Wizard 1 ,or some other cases. But he cannot sell 3 wands because no 3 wands just fit 3 wizards.

Source

Gardon-DYGG Contest 1

問題連結:HDU1179 Ollivanders: Makers of Fine Wands since 382 BC.

問題描述:有n個人要去買魔杖,有m根魔杖(由魔杖選人)。接下來是m行,每行第一個數num是第i根魔杖可以選的人數,接著num個數表示這根魔杖選的人的編號。最後問老闆最多能賣出多少根魔杖。

解題思路:二分圖最大匹配模板題。

AC的C++程式:

#include<iostream>
#include<vector>
#include<cstring>

using namespace std;

const int N=205;

vector<int>g[N];
bool vis[N];
int link[N];

bool find(int x)
{
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!vis[y])
		{
			vis[y]=true;
			if(link[y]==-1||find(link[y]))
			{
				link[y]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int n,m,num,a;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=0;i<=n+m;i++)
		  g[i].clear();
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&num);
			while(num--)
			{
				scanf("%d",&a); 
				a+=m;
				g[i].push_back(a);
				g[a].push_back(i);
			}
		}
		int ans=0;
		memset(link,-1,sizeof(link));
		for(int i=1;i<=m;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			  ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}