1. 程式人生 > >hdu 1698 Just a Hook(區間修改)

hdu 1698 Just a Hook(區間修改)

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

題意:
給你一個線段,改變該線段上區間的權值大小,求修改後該線段的權值大小;

一道模板題,被我弄成這樣,也是醉了

#include<bits/stdc++.h>
using namespace std;

const int N = 100010;

struct node
{
    int l, r, w, mark;
}tree[N<<2];

void build(int x, int l, int r)
{
    tree[x].l = l; tree[x].r = r; tree[x].w = tree[x].r - tree[x].l + 1; tree[x].mark = 0;
    if(l == r){
        return;
    }
    int m = (l+r)>>1;
    build(x<<1, l, m);
    build(x<<1|1, m+1, r);
    //tree[x].w = tree[x<<1].w + tree[x<<1|1].w;
}

void down(int x)
{
    tree[x<<1].mark = tree[x].mark;
    tree[x<<1|1].mark = tree[x].mark;
    tree[x<<1].w = (tree[x<<1].r - tree[x<<1].l + 1) * tree[x].mark;
    tree[x<<1|1].w = (tree[x<<1|1].r - tree[x<<1|1].l + 1) * tree[x].mark;
    tree[x].mark = 0;
}

void change_interval(int x, int l, int r, int s)
{
    if(tree[x].l == l && tree[x].r == r){
        tree[x].w = s * (tree[x].r - tree[x].l + 1);
        tree[x].mark = s;
        //cout << tree[x].w << endl;
        return;
    }
    if(tree[x].mark)    down(x);
    int m = (tree[x].l + tree[x].r)>>1;
    if(m >= r)  change_interval(x<<1, l, r, s);
    else if(m < l) change_interval(x<<1|1, l, r, s);
    else{
        change_interval(x<<1, l, m, s);
        change_interval(x<<1|1, m+1, r, s);
    }
    tree[x].w = tree[x<<1].w + tree[x<<1|1].w;
}

int main()
{
    int t, n, q, l, r, s, cas = 1;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        build(1, 1, n);
        scanf("%d", &q);
        while(q--){
            scanf("%d%d%d", &l, &r, &s);
            change_interval(1, l, r, s);
        }
        printf("Case %d: The total value of the hook is %d.\n", cas++, tree[1].w);
//        for(int i = 1; i <= 31; i++){
//            printf("%d\n",tree[i].w);
//        }
    }
    return 0;
}