1. 程式人生 > >程式設計基礎74 連結串列之區分無效結點,刪除結點與保留結點的方法

程式設計基礎74 連結串列之區分無效結點,刪除結點與保留結點的方法

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

一,關注點

1,本題的關鍵在於如何區分標題上這三種結點,採用的是0+num_1,max_n+num_2,2*max_n的方法,然後計算出num_1+num_2即為除無效結點外的結點,通過一次sort排序輕易可得。當初我採用在struct中加了好幾種標記的方法,繁瑣又不輕易。

二,正確程式碼

#include<cstdio>
#include<algorithm>
using namespace std;
const int max_n = 100100;
bool isExist[max_n] = { false };
struct Node {
	int address, data, next;
	int order;
}node[max_n];
bool cmp(Node a, Node b) {
	return a.order < b.order;
}
int main() {
	int begin = 0, N = 0;
	int address = 0;
	for (int i = 0; i < max_n; i++) {
		node[i].order = 2 * max_n;
	}
	scanf("%d %d", &begin, &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", &address);
		scanf("%d %d", &node[address].data, &node[address].next);
		node[address].address = address;
	}
	int Store = 0, Remove = 0, count = 0;
	int p = begin;
	while (p != -1) {
		if (isExist[abs(node[p].data)] == false) {
			isExist[abs(node[p].data)] = true;
			node[p].order = Store++;
		}
		else {
			node[p].order = max_n + Remove++;
		}
		p = node[p].next;
	}
	sort(node, node + max_n, cmp);
	count = Store + Remove;
	for (int i = 0; i < count; i++) {
		if (i != Store - 1 && i != count - 1) {
			printf("%05d %d %05d\n", node[i].address, node[i].data, node[i + 1].address);
		}
		else {
			printf("%05d %d -1\n", node[i].address, node[i].data);
		}
	}
	return 0;
}