1. 程式人生 > >POJ-Frogger(最小生成樹)

POJ-Frogger(最小生成樹)

Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

題目連結:

http://poj.org/problem?id=2253

提議描述:

給你n個點,其中1號點與2號點各有一隻青蛙,青蛙1想跳到青蛙2上,但是呢,跳的距離有限,求跳到2號青蛙位置,所經過的路段的最大值,該值最小是多少。

解題思路:

我用的是克魯斯卡爾演算法,把各個點之間的距離存起來,自己到自己的距離定義為無窮大,然後把各個點之間的距離排個序,直到1號點和2號點有共同祖先,把該路段的距離輸出,即為最小距離。

程式程式碼:

克魯斯卡爾演算法:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define inf 99999999

struct data{
	int x;
	int y;
	int u;
	int v;
	double w;
}e[40010];

int f[210];

double F(data a,data b);
int cmp(data a,data b);
int getf(int u);
int merge(int u,int v);

int main()
{
	int n,i,j,t,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		t=1;
		for(i=1;i<=n;i++)
			scanf("%d%d",&e[i].x,&e[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
				{
					e[t].u=i;
					e[t].v=j;
					e[t].w=inf;
				}	
				else
				{
					e[t].u=i;
					e[t].v=j;
					e[t].w=F(e[i],e[j]);
				}
				t++;	
			}
		sort(e+1,e+1+n*n,cmp);
		for(i=1;i<=n;i++)
			f[i]=i;
		for(i=1;i<=n*n;i++)
		{
			merge(e[i].u,e[i].v);
			if(getf(1)==getf(2))
			{
				maxn=e[i].w;
				break;
			}
		}		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,maxn);			
	}
	return 0;
} 

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

int cmp(data a,data b)
{
	return a.w<b.w;
}

int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}

int merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[v]=u;
		return 1;
	}
	return 0;
}

弗洛伊德演算法:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 99999999

struct data{
	int x;
	int y;
}a[210];

double e[210][210],dis[210];
bool book[210];

double F(data a,data b);

int n;

int main()
{
	int i,j,k,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=inf;
				else
					e[i][j]=F(a[i],a[j]);
			}
		for(k=1;k<=n;k++)
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
				{
					if(e[i][j]>max(e[i][k],e[k][j]))
						e[i][j]=max(e[i][k],e[j][k]);
				}	
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,e[1][2]);
	}	
	return 0;
}

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

prim演算法:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 99999999

struct data{
	int x;
	int y;
}a[210];

double e[210][210],dis[210];
bool book[210];

double F(data a,data b);
double prime();

int n;

int main()
{
	int i,j,k,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=inf;
				else
					e[i][j]=F(a[i],a[j]);
			}
				
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,prime());
	}	
	return 0;
}

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

double prime()
{
	int i,k,mi,u,maxn;
	for(i=1;i<=n;i++)
		dis[i]=e[1][i];
	memset(book,0,sizeof(book));
	book[1]=1;
	maxn=-1;
	for(k=1;k<n;k++)
	{
		mi=inf;
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&dis[i]<mi)
			{
				u=i;
				mi=dis[i];
			}
		}
		book[u]=1;
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&e[u][i]<dis[i])
			{
				dis[i]=min(dis[i],max(dis[u],e[u][i]));
			} 
				
		}
	}
	return dis[2];
}