1. 程式人生 > >POJ - 1463-Strategic game(最小點覆蓋)

POJ - 1463-Strategic game(最小點覆蓋)

POJ - 1463-Strategic game(最小點覆蓋)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:
在這裡插入圖片描述

the solution is one soldier ( at the node 1).
Input
The input contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
Output
The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:
Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output
1
2

  • 題目大意:
    給你一個圖(實際上是一個樹),讓你找最少的點,然後能把所有的邊都覆蓋掉,啥叫覆蓋呢?就比如題目中的那個圖吧,就是1 這個點 覆蓋三條邊,0那個點覆蓋一條邊。就是這個點所連的邊就是它所覆蓋的邊。
    這是一類問題,歸為求最小點覆蓋問題。
  • 解題思路:
    最小點覆蓋數就是最大匹配數
    證明嘛 看一下大佬的部落格吧大佬部落格因為我是個菜雞,所以我個人認為,掌握這個證明並不是必須的,只要你能記住這個定理就好啦。至於怎麼求最大匹配,就是用匈牙利演算法求了。
  • AC程式碼:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn=1501;
struct node
{
	int to;
	int next;
}side[maxn*2];
int used[maxn];
int head[maxn];
int ans[maxn];//用來存答案
int vis[maxn];//用來分二分圖的
int cnt=0;
int n;
void init()
{
	memset(head,-1,sizeof(head));
	memset(ans,0,sizeof(ans));
	memset(used,0,sizeof(0));
	cnt=0;
}
void add(int x,int y)
{
	side[cnt].to=y;
	side[cnt].next=head[x];
	head[x]=cnt++;
}
bool dfs(int x)
{
	for(int i=head[x];i!=-1;i=side[i].next)
	{
		int y=side[i].to;///與x相連線的點
		if(used[y]==0)
		{
			used[y]=1;
			if(ans[y]==0||dfs(ans[y])) 
			{
				ans[y]=x;
				return true;
			}
		}
	}
	return false;
}
int solve()
{
	int sum=0;
	memset(ans,0,sizeof(ans));
	for(int i=0;i<n;i++)
	{
		memset(used,0,sizeof(used));
		if(dfs(i))
			sum++;
	}
	return sum;
}
int main()
{
	while(cin>>n)
	{
		init();
		for(int i=0;i<n;i++)
		{
			int t,k;
		    scanf("%d:(%d)",&t,&k);
			while(k--)
			{
				int v;
				cin>>v;
				add(t,v);
				add(v,t);
			}
		}
		int s=solve();
		cout<<s/2<<endl;		
	}
	
	return 0;
}