1. 程式人生 > >PAT 1027 Colors in Mars

PAT 1027 Colors in Mars

 

1027 Colors in Mars (20 分)

   People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue

. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

  Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

  For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

 程式碼

 

//進位制轉換
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
void op(int x)
{
    int temp,n;
    char c[10];
    n=0;
    while(x)
    {
        temp=x%13;
        if(temp>9)
           c[n]=temp-10+'A';
        else
           c[n]=temp+'0';
        x/=13;
        n+=1;
    }
    if(n==0)
        printf("00");
    else
    {
        if(n<2)
          printf("0");
        for(int i=n-1;i>=0;i--)
          printf("%c",c[i]);
    }
}
int main()
{
    int x,y,z;
    scanf("%d %d %d",&x,&y,&z);
    printf("#");
    op(x);
    op(y);
    op(z);
    return 0;
}