1. 程式人生 > >POJ——2411 Mondriaan's Dream (狀壓 dp)

POJ——2411 Mondriaan's Dream (狀壓 dp)

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

此題題解可以作為模板!!!!打表找規律!!!作為菜雞的我還不是很懂狀壓dp~~~

題意:有一個h行w列的大矩形,你可以在裡放1*2的長方形,長方形之間互相不重疊,問放滿整個大矩形有多少種方案數。

題解:狀壓dp,看到資料小於20的一般就是狀壓dp;上程式碼:

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 12;
typedef long long ll;
int n,m,tot;//n是行,m是列
ll f[MAX][1<<MAX];
bool check(int state){
	for (int i = 0; i < m;i++){
		if(state&(1<<i)){
			if(!(state&(1<<i+1)))return 0;
			i++;
		}
	}
	return 1;
}
int main(){
	while(cin >> n >> m,n+m){
		if((n*m)&1){
			cout << 0 << endl;
			continue;
		}
		memset(f,0,sizeof(f));
		if(n<m) swap(n,m);
		tot=(1<<m)-1;
		for (int i = 0; i <= tot;i++) if(check(i)) f[1][i]=1;
		for (int i = 2; i <= n;i++){
			for (int j = 0; j <= tot;j++){
				for (int k = 0; k <= tot;k++){
					if((tot^j)&(tot^k)) continue;
					if(!check(((tot^k)&j)^j)) continue;
					f[i][j]+=f[i-1][k];
				}
			}
		}
		cout << f[n][tot] << endl;
	}
	return 0;
}