1. 程式人生 > >HDU 1520 Anniversary party(樹形dp) 題解

HDU 1520 Anniversary party(樹形dp) 題解

題目來源:

題目描述:

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:  L K  It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line  0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output

5

Source

Recommend

linle

解題思路:

      樹形dp的入門題,我們只要用dp【i】【0/1】1表示從選i的最大值,0表示不選i的最大值,可以知道,如果v是u的葉子節點,dp【u】【0】+=min(dp【v】【1】,dp【v】【0】),dp【u】【1】+=dp【v】【0】;

ans=max(dp[i][0],dp[i][1]);i為入度為0的點,也是起點。

程式碼:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int  maxn=6*1e3+10;
int n,dp[maxn][2],head[maxn],rd[maxn],cnt=0;
struct newt
{
	int to,next;
}e[maxn*maxn];
void addedge(int u,int v)
{
	e[cnt].to=v;
	e[cnt].next=head[u];
	head[u]=cnt++;
}
void dfs(int u)
{
//	for(int i=head[u];i!=-1;i=e[i].next)
//	{
//		int v=e[i].to;
//		dfs(v);
//	}
	for(int i=head[u];i!=-1;i=e[i].next)
	{
		int v=e[i].to;
		dfs(v);
		dp[u][1]+=dp[v][0];
		dp[u][0]+=max(dp[v][0],dp[v][1]);
	}
}
int main()
{
	
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		memset(head,-1,sizeof(head));
		for(int i=1;i<=n;i++)scanf("%d",&dp[i][1]);
		int a,b;
		while(scanf("%d%d",&a,&b)!=EOF)
		{
			if(a==0&&b==0)break;
			addedge(b,a);
			rd[a]++;
		}
		for(int i=1;i<=n;i++)
		{
			if(!rd[i])
			{
				dfs(i);
				printf("%d\n",max(dp[i][0],dp[i][1]));
				break;
			}
		}
	}
	
	
	return 0;
}