1. 程式人生 > >HDU 2602 Bone Collector

HDU 2602 Bone Collector

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

14

01揹包的簡單應用

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#define MAX 1<<30;
using namespace std;
int a, b, c, l, m, n, h, e;
int dp[1001],x[1001], y[1001];
int main()
{
    scanf("%d", &n);
    while (n--)
    {
        scanf("%d %d", &b, &c);
        for (int i = 0; i<b; i++)
        {
            scanf("%d", &x[i]);
        }
        for (int i = 0; i<b; i++)
        {
            scanf("%d", &y[i]);
        }
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i<b; i++)
        {
            for (int j = c; j >= y[i]; j--)
            {
                dp[j] = max(dp[j], dp[j - y[i]] + x[i]);
            }
        }
        printf("%d\n", dp[c]);
    }
}