1. 程式人生 > >PAT (Advanced Level) Practice 1142

PAT (Advanced Level) Practice 1142

1142 Maximal Clique(25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory

))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes

 if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

剛開始沒看懂題意,後來根據樣例看懂。就是給你的幾個點,判斷是不是連通,如果相互不連通,輸出Not a Clique。然後判斷是不是最大的兩兩相互的連通,如果不是,那麼輸出Not Maximal否則輸出Yes。

#include<cstdio>
#include<vector>
using namespace std;
#define N 210
int vertics[N][N];
int v, e;
vector<int> vec, least;
bool isMaxmal(){
	least.clear();
	for(int i = 1;i <= v;i++){
		bool f = false;
		for(int j = 0;j < vec.size();j++){
			if(i == vec[j]){
				f = true;
				break;
			}
		}	
		if(!f){
			least.push_back(i);
		}
	}
	for(int i = 0;i < least.size();i++){
		int c = 0;
		for(int j = 0;j < vec.size();j++){
			if(vertics[least[i]][vec[j]] == 1){
				c++;
			}
		}
		if(c == vec.size()){
			return false;
		}
	}
	return true;
}
bool isClique(){
	int len = vec.size();
	for(int i = 0;i < len;i++){
		for(int j = i + 1;j < len;j++){
			if(vertics[vec[i]][vec[j]] != 1){
				return false;
			}
		}
	}
	return true;
}
int main(){
	scanf("%d %d", &v, &e);
	for(int i = 0;i < e;i++){
		int a, b;
		scanf("%d %d", &a, &b);
		vertics[b][a] = vertics[a][b] = 1;
	}
	int q;
	scanf("%d", &q);
	for(int i = 0;i < q;i++){
		int n;
		scanf("%d", &n);
		vec.clear();
		for(int j = 0;j < n;j++){
			int t;
			scanf("%d", &t);
			vec.push_back(t);
		}
		if(isMaxmal() && isClique()){
			printf("Yes\n");
		}else if(isClique() && !isMaxmal()){
			printf("Not Maximal\n");
		}else{
			printf("Not a Clique\n");
		}
		
	}
	return 0;
}