1. 程式人生 > >LIghtOJ-1341-Aladdin and the Flying Carpet (唯一分解定理)

LIghtOJ-1341-Aladdin and the Flying Carpet (唯一分解定理)

原題連結:
It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2

10 2

12 2

Sample Output
Case 1: 1

Case 2: 2
題意:
輸入一個n和b,找出n的所有的因子組合(x,y)要求x*y==n,其中x,y都要大於b。
題解:
先素數打表,然後利用唯一分解定理,找出所有的因子的個數,最終除以二,得到的是所有的組合可能,再減去小於b的組合個數。
附上AC程式碼:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define LL long long
const int N=1e6+5;
const int NN=1e5;
int prime[NN],cnt=0;
bool vis[N];
void el()//素數打表
{
    memset(vis,0,sizeof(vis));
    for(int i=2;i<N;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
            for(int j=i+i;j<N;j+=i)
            {
                vis[j]=1;
            }
        }
    }
}

int main()
{
    el();
    int t;
    LL a,b;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        LL st=1;
        scanf("%lld%lld",&a,&b);
        if(a<b*b)
        {
            printf("Case %d: 0\n", cas);
            continue;
        }
        LL n=a;
        for(int i=0;i<cnt&&prime[i]*prime[i]<=a;i++)
        {
            if(a%prime[i]==0)
            {
                int num=0;
                while(a%prime[i]==0)
                {
                    a/=prime[i];
                    num++;
                }
                st*=(1+num);//約數的個數
            }
        }
        if(a>1)
            st*=2;//如果沒有分解完,則剩餘一個素數,則乘以(1+1—)
        st/=2;
        for(LL i=1;i<b;i++)
        {
            if(n%i==0)//去除掉所有的小於b的因子個數
                st--;
        }
        printf("Case %d: %lld\n",cas,st);
    }
    return 0;
}

歡迎評論!