1. 程式人生 > >poj2926 Requirements(多維曼哈頓距離模板題)

poj2926 Requirements(多維曼哈頓距離模板題)

Requirements

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4474 Accepted: 1563

Description

An undergraduate student, realizing that he needs to do research to improve his chances of being accepted to graduate school, decided that it is now time to do some independent research. Of course, he has decided to do research in the most important domain: the requirements he must fulfill to graduate from his undergraduate university. First, he discovered (to his surprise) that he has to fulfill 5 distinct requirements: the general institute requirement, the writing requirement, the science requirement, the foreign-language requirement, and the field-of-specialization requirement. Formally, a requirement is a fixed number of classes that he has to take during his undergraduate years. Thus, for example, the foreign language requirement specifies that the student has to take 4 classes to fulfill this requirement: French I, French II, French III, and French IV. Having analyzed the immense multitude of the classes that need to be taken to fulfill the different requirements, our student became a little depressed about his undergraduate university: there are so many classes to take…

Dejected, the student began studying the requirements of other universities that he might have chosen after high school. He found that, in fact, other universities had exactly the same 5 requirements as his own university. The only difference was that different universities had different number of classes to be satisfied in each of the five requirement.

Still, it appeared that universities have pretty similar requirements (all of them require a lot of classes), so he hypothesized that no two universities are very dissimilar in their requirements. He defined the dissimilarity of two universities X and Y as |x1 − y1| + |x2 − y2| + |x3 − y3| + |x4 − y

4| + |x5 − y5|, where an xi (yi) is the number of classes in the requirement i of university X (Y) multiplied by an appropriate factor that measures hardness of the corresponding requirement at the corresponding university.

Input

The first line of the input file contains an integer N (1 ≤ N ≤ 100 000), the number of considered universities. The following N lines each describe the requirements of a university. A university X is described by the five non-negative real numbers xxxxx5.

Output

On a single line, print the dissimilarity value of the two most dissimilar universities. Your answer should be rounded to exactly two decimal places.

Sample Input

3
2 5 6 2 1.5
1.2 3 2 5 4
7 5 3 2 5

Sample Output

12.80

Source

題解:

模板。

然而過不去(網上也只找到了一個過的去的)

程式碼:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iomanip>
using namespace std;
int n,i,j,k;
double mx,mn,ans,sum,b[100001],a[100001][5];
int main(){
	while(~scanf("%d",&n)){
	for(i=1;i<=n;i++){
		scanf("%lf%lf%lf%lf%lf",&a[i][0],&a[i][1],&a[i][2],&a[i][3],&a[i][4]);
	}
	ans=-1e200;
	for(i=0;i<(1<<5);i++){
		mx=-1e200;mn=1e200;
		for(j=1;j<=n;j++){
			sum=0;
		 for(k=0;k<=4;k++)
		  if(i&(1<<k))sum+=a[j][k];
		   else sum-=a[j][k];
		mx=max(mx,sum);
		mn=min(mn,sum);   
	}
	    ans=max(ans,mx-mn);
	}
	printf("%.2lf\n",ans);
}
}