1. 程式人生 > >[Python](PAT)1035 Password (20 分)

[Python](PAT)1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %

l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified

 where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 [email protected]

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

題目大意

給定N個帳號密碼,如果密碼中包含容易混淆的字元,則將其更改為其他字元。

輸出修改了幾個帳號並輸出修改後的帳號密碼。如果沒有修改,則輸出沒有修改的帳號密碼數量,注意單複數的區別。

python實現

def main():
    n = int(input())
    count = n
    a = {'1':'@','0':'%','l':'L','O':'o'}
    result = []
    for x in range(n):
        line = input().split(" ")
        flag = False
        for i in a:
            if i in line[1]:
                flag = True
                line[1] = line[1].replace(i,a[i])
        if flag:
            result.append([line[0], line[1]])
            count -= 1
    if len(result) !=0:
        print(len(result))
        for x in result:
            print(x[0],x[1])
    elif count > 0 :
        if count == 1:
            print('There is 1 account and no account is modified')
        else:
            print('There are {} accounts and no account is modified'.format(count))
        
if __name__ == "__main__":
    main()