1. 程式人生 > >HDOJ4006 The kth great number --優先佇列求第k大數

HDOJ4006 The kth great number --優先佇列求第k大數

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 7004    Accepted Submission(s): 2857  

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q

Sample Output

1 2 3

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
priority_queue<int,vector<int>,greater<int> > q;            // 小頂堆
// main() 是程式開始執行的地方

int main()
{
    int n,k;        // 輸入n行,求K大數
    while (scanf("%d%d",&n,&k) != EOF) {
        while(!q.empty()) q.pop();          //清空佇列
        char input;
        int num;
        int temp;
        for(int i = 0;i < n;i++) {
        	getchar();
            scanf("%c",&input);            
            if(input == 'I') {
                scanf("%d",&num);              
            	q.push(num);
                while(q.size() > k)
					q.pop();
            } else if (input == 'Q') {
                printf("%d\n",q.top());
            }
        }
        
        
    }
    
    return 0;
}