1. 程式人生 > >1152 Google Recruitment (20 point(s)

1152 Google Recruitment (20 point(s)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越數). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.  //當時被這句話弄糊塗了,以為是第一個2不能被當成答案。這句話容易誤導(愚見)

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

題目大意:給一串長L的字串,輸出子串長度為K的第一個素數。不能在源字串前添0。程式碼如下:

#include <iostream>
#include <string>
#include <cmath>
#include <cstdio>
using namespace std;
bool isPrime(int num)
{
	if(num<2)	return false;
	for(int i=2;i<=sqrt(num);i++){
		if(num%i==0)	return false;
	}
	return true;
}
int main()
{
//	freopen("1152.txt","r",stdin);
	int n,k;
	string str;
	cin>>n>>k>>str;
	int flag=0;
	for(int i=0;i<str.length()-k+1;i++){    
		string tmp=str.substr(i,k);    //取出長度為K的子串
		int num=stoi(tmp);            //轉化為int型別判斷是否是素數
		if(isPrime(num)){
			cout<<tmp;
			return 0;                //第一次找到直接輸出,並return 0
		}
	}
	cout<<"404";                    //未找到輸出“404”
	return 0;	
}