1. 程式人生 > >HDU4280:Island Transport(最大流)

HDU4280:Island Transport(最大流)

Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 13187    Accepted Submission(s): 4156

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=4280

Description:

  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.

Input:

  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.

Output:

  For each test case, output an integer in one line, the transport capacity.

Sample Input:

2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4

Sample Output:

9 6

題意:
給出n個點的座標,然後會給出點與點之間的連線關係以及邊的權值,問從最左邊的點到最右邊的點經過邊的權值和最大為多少。

 

題解:
這道題和普通最大流的區別就是,這裡是雙向邊,所以只需要稍微變一下就可以了。

在以前單向邊的圖中,我們建立了容量為0的反向邊,之後會增加反向邊的容量以便於進行”反悔操作“。

這裡也同樣,但是建反向邊時容量與正向邊相等,可以想一想為什麼。只要理解了最大流的演算法應該就比較好想。

 

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#define INF 99999999
using namespace std;
typedef long long ll;
const int N = 1e5+5 ;
int T,s,t,u,v,tot,n,m;
int head[N],d[N];
struct Edge{
    int v,next,c;
}e[N<<1];
void adde(int u,int v,int c){
    e[tot].v=v;e[tot].next=head[u];e[tot].c=c;head[u]=tot++;
    e[tot].v=u;e[tot].next=head[v];e[tot].c=c;head[v]=tot++;
}
int bfs(){
    memset(d,0,sizeof(d));d[s]=1;
    queue<int> q;q.push(s);
    while(!q.empty()){
        int u=q.front();q.pop();
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(!d[v] &&e[i].c>0){
                d[v]=d[u]+1;
                q.push(v);
            }
        }
    }
    return d[t]!=0;
}
int dfs(int u,int a){
    if(u==t || a==0) return a;
    int flow=0,f;
    for(int i=head[u];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(d[v]!=d[u]+1) continue ;
        f=dfs(v,min(a,e[i].c));
        if(f>0){
            flow+=f;
            e[i].c-=f;
            e[i^1].c+=f;
            a-=f;
            if(a==0) break ;
        }
    }
    if(!flow) d[u]=-1;
    return flow;
}
int Dinic(){
    int flow= 0;
    while(bfs()) flow+=dfs(s,INF);
    return flow;
}
int main(){
    scanf("%d",&T);
    while(T--){
        tot=0;memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        int minx = 99999999,maxx = -99999999 ;
        for(int i=1,u,v;i<=n;i++){
            scanf("%d%d",&u,&v);
            if(minx>u){
                minx=u;s=i;
            }
            if(maxx<u){
                maxx=u;t=i;
            }
        }
        for(int i=1,u,v,c;i<=m;i++){
            scanf("%d%d%d",&u,&v,&c);
            adde(u,v,c);
        }
        printf("%d\n",Dinic());
    }
    return 0;
}