1. 程式人生 > >poj--3630 Phone List(Trie字典樹)

poj--3630 Phone List(Trie字典樹)

3630-Phone List

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34575 Accepted: 9924

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t

≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

【題意】給定n個長度不超過10的字串,判斷是否有一個串為另一個串的字首。

【注意】有輸出NO,無輸出YES。

【分析】將所有字串構成一棵Trie,並可以在構建過程中順便判斷答案。若當前串插入後沒有新建任何結點,則當前串必然為已插入的某個串的字首;若插入過程中,有某個經過的結點已經到達串結尾標記,則之前插入的某個串是該串的字首。

【程式碼】

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=1e5+5;
const int z=10;
int t,n,tot;
int ch[maxn][z];
bool tag[maxn];
char s[20];
void clear()
{
	memset(ch,0,sizeof(ch));
	memset(tag,false,sizeof(tag));
}
bool insert(char *s)
{
	int len=strlen(s);
	int u=1;//根節點為1 
	bool flag=false;
	for(int i=0;i<len;i++)
	{
	    int c=s[i]-'0';
	    if(!ch[u][c])
	    	ch[u][c]=tot++;
	    else if(i==len-1)
		flag=true;
            u=ch[u][c];
	    if(tag[u])
		flag=true;//經過有標記點 
	}
	tag[u]=true;//結尾標記
	return flag;
}
int main()
{
	scanf("%d",&t);
	while(t--)
	{
	    scanf("%d",&n);
	    tot=1;//建立一個空節點作為字典樹的根
	    clear();
	    bool ans=false;
	    for(int i=1;i<=n;i++)
	    {
	    	scanf("%s",s);//cout<<"OK\n";
	    	if(insert(s))
	    	    ans=true;
	    } 
	    if(ans)printf("NO\n");
	    else printf("YES\n");
	}
	return 0;
}

摘於書《資訊學奧賽》