1. 程式人生 > >PAT甲級1013 (圖,DFS)

PAT甲級1013 (圖,DFS)

題目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input 3 2 3 1 2 1 3 1 2 3 Sample Output 1 0 0

題解

//保證剩餘城市的連線
#include<iostream>
#include<algorithm>
using namespace std;
bool vis[1001];
int G[1001][1001];
int n;
void dfs(int node){
  vis[node]=true;
  for(int i=1;i<=n;i++){
     if(vis[i]==false&&G[node][i]==1){
     dfs(i);
  }
}
 
}
int main(){
  int m,k;
  scanf("%d%d%d", &n, &m, &k);
  int u,v;
  for(int i=0;i<m;i++){
    scanf("%d%d", &u, &v);
    G[u][v]=G[v][u]=1;
  }
  for(int i=0;i<k;i++){
    fill(vis,vis+1001,false);
    int a;
    scanf("%d",&a);
    vis[a]=true;
    //去除選中點與其他點的連線
    int cnt=0;
    for(int j=1;j<=n;j++){
      if(vis[j]==false){
        dfs(j);
        cnt++;
      }
    }
    //判斷剩下點是否聯通,不聯通輸出新增的路的條數,聯通為0
    //退回仍有未訪問分支的岔路口
     printf("%d\n",cnt-1);
  }
  return 0;
}

DFS這塊一直理解得不是太好。 思路是隻要有去除的點外的點沒有訪問,就進入dfs迭代。迭代一次說明不用加路,迭代n次說明有n塊未連通區域,需要n-1條路。