1. 程式人生 > >2318 TOYS

2318 TOYS

Calculate the number of toys that land in each bin of a partitioned toy box.  Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.  John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

題目大意:一個矩形被分成若干個區域,給你一個座標,判斷在那個區域內,最後輸出所以區域內座標數

解題思路: 把每一個隔板看作一個向量,方向為從底邊指向頂邊,用a表示,另一個向量為從隔板底邊定點指向所給座標,

用b表示,則向量a叉乘向量b,如果結果為正,則該座標在隔板左邊位置,如果為負,則該座標在隔板右邊位置

注意:這種判斷座標在隔板左側還是右側僅使用於當前向量的取值與方向以及叉乘順序。向量選取不同判斷不同,當選用

其他向量時,可以先驗證一下結果為正或者為負時,座標在隔板的左邊還是右邊,因為具有通用性嘛

AC程式碼:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=5e3+10;
struct	node{
	int x1,x2;//x1儲存上頂點的x座標,x2儲存下定點 的x座標 
}a[maxn];
int ans[maxn];//儲存最後的輸出結果; 
int main()
{
	int i,j;
	int m,n,X1,Y1,X2,Y2;
	while(cin>>n,n)
	{
		memset(ans,0,sizeof(ans));
		cin>>m>>X1>>Y1>>X2>>Y2;
		a[0].x1=a[0].x2=X1;//記錄最右邊,因為是直線,X1=X2; 
		a[n+1].x1=a[n+1].x2=X2;//記錄最左邊的邊 
		int U,L;
		for(i=1;i<=n;i++)
		{
			cin>>a[i].x1>>a[i].x2;
		}
		for(i=0;i<m;i++)
		{
			cin>>U>>L;
			for(j=1;j<=n;j++)
			{
				int term=(a[j].x1-a[j].x2)*(L-Y2)-(Y1-Y2)*(U-a[j].x2);//叉乘 
				if(term>0)//叉乘為正說明現在的玩具位置在當前邊的左邊 
				{
					break;
				}
			}
			ans[j-1]++;//因為在當前邊的左邊所以j-1分隔間數量加一 
		}
		for(int i=0;i<=n;i++)
		{
			printf("%d: %d\n",i,ans[i]);
		}
		printf("\n");
	}
	return 0;
}