1. 程式人生 > >【題解】poj2228 Naptime 線性DP+環形處理

【題解】poj2228 Naptime 線性DP+環形處理

題目連結

Description

Goneril is a very sleep-deprived cow. Her day is partitioned into N (3 <= N <= 3,830) equal time periods but she can spend only B (2 <= B < N) not necessarily contiguous periods in bed. Due to her bovine hormone levels, each period has its own utility U_i (0 <= U_i <= 200,000), which is the amount of rest derived from sleeping during that period. These utility values are fixed and are independent of what Goneril chooses to do, including when she decides to be in bed.

With the help of her alarm clock, she can choose exactly which periods to spend in bed and which periods to spend doing more critical items such as writing papers or watching baseball. However, she can only get in or out of bed on the boundaries of a period.

She wants to choose her sleeping periods to maximize the sum of the utilities over the periods during which she is in bed. Unfortunately, every time she climbs in bed, she has to spend the first period falling asleep and gets no sleep utility from that period.

The periods wrap around in a circle; if Goneril spends both periods N and 1 in bed, then she does get sleep utility out of period 1.

What is the maximum total sleep utility Goneril can achieve?

Input

  • Line 1: Two space-separated integers: N and B

  • Lines 2…N+1: Line i+1 contains a single integer, U_i, between 0 and 200,000 inclusive

Output

The day is divided into 5 periods, with utilities 2, 0, 3, 1, 4 in that order. Goneril must pick 3 periods. Sample Input 5 3 2 0 3 1 4

Sample Output

6

Hint

INPUT DETAILS:

The day is divided into 5 periods, with utilities 2, 0, 3, 1, 4 in that order. Goneril must pick 3 periods.

OUTPUT DETAILS:

Goneril can get total utility 6 by being in bed during periods 4, 5, and 1, with utilities 0 [getting to sleep], 4, and 2 respectively.

F[i,j,1]F[i,j,1] 表示前 ii 個小時休息了 jj 個小時,並且第 ii 個小時正在休息,累計恢復體力的最大值。 F[i,j,1]F[i,j,1] 同理。 F[i,j,0]=max(F[i1,j,0],F[i1,j,1])F[i,j,0]=\max(F[i-1,j,0],F[i-1,j,1]) F[i,j,1]=max(F[i1,j1,0],F[i1,j1,1]+Ui)F[i,j,1]=\max(F[i-1,j-1,0],F[i-1,j-1,1]+U_i) 初值 F[1,0,0]=0,F[1,1,1]=0F[1,0,0]=0,F[1,1,1]=0,其餘為負無窮。 但是沒有考慮第一個小時在休息。所以強制令 F[1,1,1]=U1F[1,1,1]=U_1,其餘為負無窮,再 dpdp 一遍,最後答案為最大值。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=4e3+10;
int n,b,f[N][2],u[N],ans;
void dp()
{
	for(int i=2;i<=n;i++)
	{
		for(int j=b;j;j--)
		{
			f[j][0]=max(f[j][0],f[j][1]);
			f[j][1]=max(f[j-1][0],f[j-1][1]+u[i]);
		}
	}	
}
int main()
{
	//freopen("in.txt","r",stdin);
    scanf("%d%d",&n,&b);
    for(int i=1;i<=n;i++)
        scanf("%d",&u[i]);
    memset(f,0xcf,sizeof(f));
    f[0][0]=f[1][1]=0;
	dp();
	ans=max(ans,max(f[b][0],f[b][1]));
	memset(f,0xcf,sizeof(f));
	f[1][1]=u[1];
	dp();
	ans=max(ans,f[b][1]);
	printf("%d\n",ans);
	return 0;
}

總結

把問題用兩部分覆蓋,於是把環形轉化成兩次線性DP。