1. 程式人生 > >(甲)1001 A+B Format

(甲)1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

key 

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int a,b,sum,t=0;
	cin>>a>>b;
	sum=a+b;
	if(sum<0) cout<<"-";
	sum=fabs(sum);
	if(sum>=1000000) printf("%d,%03d,%03d",sum/1000000,sum%1000000/1000,sum%1000);
	else if(sum>=1000) printf("%d,%03d",sum/1000,sum%1000);
	else cout<<sum;
	return 0;
}