1. 程式人生 > >【凸包+旋轉卡殼(最遠點對)】POJ

【凸包+旋轉卡殼(最遠點對)】POJ

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates.  Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms.   

Input

* Line 1: A single integer, N  * Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

給你n個點,求最遠兩點的距離

因為n有50000,所以直接暴力輪肯定會超時的

用凸包的graham方法,得到最大凸多邊形,那麼一定是在凸多邊形上的一對點是最遠點

接下來用旋轉卡殼的方法

因為凸包上的點依次與對應邊產生的距離成單峰函式

所以,逆時針列舉邊時,最遠點的變化也是逆時針的

最遠點對必然屬於對蹱點集合

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=50005;
struct point
{
    int x,y;
}pt[maxn],ans[maxn];
int cross(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int dist(point s,point e)
{
    return (s.x-e.x)*(s.x-e.x)+(s.y-e.y)*(s.y-e.y);
}
int cmp(point a,point b)  //極角排序
{
    if(cross(pt[0],a,b)>0) return 1;
    if(cross(pt[0],b,a)==0&&dist(pt[0],b)>dist(pt[0],a)) return 1;
    return 0;
}
int graham(int n)
{
    int top=2;
    sort(pt+1,pt+n,cmp);
    ans[0]=pt[0],ans[1]=pt[1],ans[2]=pt[2];
    for(int i=3;i<n;i++)
    {
        while(top>=1&&cross(ans[top-1],ans[top],pt[i])<=0) top--;
        ans[++top]=pt[i];
    }
    return top;
}

int qiake(int top)
{
    int q=1,res=0;
    ans[top+1]=ans[0];
    for(int i=0;i<=top;i++)
    {
        while(cross(ans[i+1],ans[q],ans[i])<cross(ans[i+1],ans[q+1],ans[i]))
            q=(q+1)%top;
        res=max(res,max(dist(ans[i],ans[q]),dist(ans[i+1],ans[q+1])));
    }
    return res;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&pt[i].x,&pt[i].y);
        int k=0;
        for(int i=0;i<n;i++)
        {
            if((pt[k].y>pt[i].y)||(pt[k].y==pt[i].y&&pt[k].x>pt[i].x)) k=i;
        }
        swap(pt[0],pt[k]);
        int top=graham(n);
        int res=qiake(top);
        printf("%d\n",res);
    }
    return 0;
}