1. 程式人生 > >hdoj087:Super Jumping! Jumping! Jumping!(dp基礎題-最大上升子序列和(可不連續))

hdoj087:Super Jumping! Jumping! Jumping!(dp基礎題-最大上升子序列和(可不連續))

目錄

題目解釋:

解題思路:

ac程式碼:

Super Jumping! Jumping! Jumping!

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 14   Accepted Submission(s) : 12

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.  

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow: N value_1 value_2 …value_N  It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

題目解釋:

輸入棋子上對應的value,只能從value低的棋子跳到value高的棋子,可連續跳,也可間隔棋子跳,最後輸出所走路徑上的value之和的最大值。

解題思路:

最大上升子序列和(可以不連續)

狀態轉移方程:dp[i]=max{dp[j]}+dp[i](dp[i]初始化為a[i],j<i,a[j]<a[i])

ac程式碼:

#include <iostream>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <queue>
#define ll long long int
using namespace std;
int main()
{
    int n,i,j;
    int a[1005];
    while(scanf("%d",&n)&& n!=0)
    {
        ll dp[1005];
        ll ans=INT_MIN;
        for(i=0;i<n;i++)
        {
            scanf("%d", &a[i]);
            dp[i]=a[i];
        }
        for(i=0;i<n;i++)
        {
            int temp=0;
            for(j=0;j<i;j++)
            {
                if(a[j]<a[i])
                {
                    if(dp[j]>temp)
                        temp=dp[j];
                }
            }
            dp[i]+=temp;
            ans=max(dp[i],ans);
        }
        printf("%lld\n",ans);
    }
    return 0;
}