1. 程式人生 > >3261 Connections in Galaxy War (逆向並查集)

3261 Connections in Galaxy War (逆向並查集)

Connections in Galaxy War

Time Limit: 3 Seconds      Memory Limit: 32768 KB

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A

. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

和下面這道題類似

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 10005;
int val[MAXN],pre[MAXN];
struct node
{
    char op[2];
    int u,v;
}q[5 * MAXN],jo[2 * MAXN];
int ans[5 * MAXN];
bool vis[MAXN * 2];
map<int,int> M[MAXN];
int Find(int x)
{
    if(x == pre[x]) return pre[x];
    else return pre[x] = Find(pre[x]);
}
void join(int x,int y)
{
    int fx = Find(x);
    int fy = Find(y);
    if(fx > fy) {
        swap(fx,fy);
    }
    if(fx != fy) {
        if(val[fx] >= val[fy]) pre[fy] = fx;
        else pre[fx] = fy;
    }
}
int main(void)
{
    int n,m,u,v,k;
    int flag = 0;
    while(scanf("%d",&n) != EOF) {
        if(!flag) flag = 1;
        else printf("\n");
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++) {
            pre[i] = i;
            M[i].clear();
            scanf("%d",&val[i]);
        }
        int m;
        scanf("%d",&m);
        for(int i = 0; i < m; i++) {
            scanf("%d %d",&u,&v);
            if(u > v) {
                swap(u,v);
            }
            jo[i].u = u;
            jo[i].v = v;
            M[u][v] = i;
        }
        scanf("%d",&k);
        for(int i = 0; i < k; i++) {
            scanf("%s",q[i].op);
            if(q[i].op[0] == 'd') {
                scanf("%d %d",&u,&v);
                if(u > v) {
                    swap(u,v);
                }
                vis[M[u][v]] = 1;
                q[i].u = u;
                q[i].v = v;
            }
            else {
                scanf("%d",&q[i].u);
            }
        }
        for(int i = 0; i < m; i++) {
            if(!vis[i]) {
                join(jo[i].u,jo[i].v);
            }
        }
        for(int i = k - 1; i >= 0; i--) {
            if(q[i].op[0] == 'd') {
                join(q[i].u,q[i].v);
            }
            else {
                int fu = Find(q[i].u);
                ans[i] = (val[fu] > val[q[i].u] ? fu : -1);
            }
        }
        for(int i = 0; i < k; i++) {
            if(q[i].op[0] == 'q') {
                printf("%d\n",ans[i]);
            }
        }
    }
    return 0;
}
/*
2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1
*/