1. 程式人生 > >Longest Ordered Subsequence (最長遞增子序列)

Longest Ordered Subsequence (最長遞增子序列)

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).  Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

最長遞增子序列:簡單一維DP,DP[i]表示前n個數的最長子序列!

#include <iostream>
#include<math.h>
#include<string.h>
#include<stdio.h>
using namespace std;
const int N=2005;
int a[N],dp[N];
int my_max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(int i=1; i<=n; i++)
            dp[i]=1;
        int man=1;
        for(int i=2; i<=n; i++)
        {
            for(int j=1; j<i; j++)
            {
                if(a[i]>a[j])
                {
                    dp[i]=my_max(dp[i],dp[j]+1);
                }
            }
            man=my_max(dp[i],man);
        }
        printf("%d\n",man);
    }
    return 0;
}