1. 程式人生 > >HDU 1072 Nightmare(廣搜BFS)

HDU 1072 Nightmare(廣搜BFS)

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes. Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1. Here are some rules: 1. We can assume the labyrinth is a 2 array. 2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth. 4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb. 5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. There are five integers which indicate the different type of area in the labyrinth: 0: The area is a wall, Ignatius should not walk on it. 1: The area contains nothing, Ignatius can walk on it. 2: Ignatius' start position, Ignatius starts his escape from this position. 3: The exit of the labyrinth, Ignatius' target position. 4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

Sample Output

4

-1

13

這道題也算是比較簡單的搜尋題,題意是說需要在炸彈爆炸之前走出迷宮,如果迷宮為“4”,炸彈爆炸時間重置為6,“0”是牆,“1”是路,“2”為入口,“3”為出口,需要注意的就是時間的計算。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<string.h>
using namespace std;
int map[10][10];
int dir[][2] = { -1,0,1,0,0,1,0,-1 };//方向座標
int n, m, bx, by;
struct zzz
{
    int x, y, time, time1;//time為炸彈時間,time1為走迷宮的時間
} t, z;
void bfs()//廣搜
{
    queue<zzz>q;
    z.x = bx;
    z.y = by;
    z.time = 6;//炸彈初始時間為6s
    z.time1 = 0;//記錄走的時間
    q.push(z);
    while (!q.empty())
    {
        z = q.front();
        q.pop();
        for (int i = 0; i < 4; i++)
        {
            t.x = z.x + dir[i][0];
            t.y = z.y + dir[i][1];
            t.time = z.time - 1;
            t.time1 = z.time1 + 1;
            if (t.x >= 0 && t.x < n&&t.y >= 0 && t.y < m&&map[t.x][t.y] != 0 && t.time>0)//判斷是否越界和超時
            {
                if (map[t.x][t.y] == 3)//如果為3,則輸出走的時間
                {
                    printf("%d\n", t.time1);
                    return;
                }
                if (map[t.x][t.y] == 4)//為4,重置炸彈爆炸時間
                {
                    t.time = 6;
                    map[t.x][t.y] = 0;
                }
                q.push(t);
            }
        }
    }
    printf("-1\n");
}
int main()
{
    int sss;
    cin >> sss;
    while (sss--)
    {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < m; j++)
            {
                cin >> map[i][j];
                if (map[i][j] == 2)//記錄初始位置
                {
                    bx = i;
                    by = j;
                }
            }
        }
        bfs();