1. 程式人生 > >hdu1260(遞推+處理時間)(18.10.2)

hdu1260(遞推+處理時間)(18.10.2)

Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 1) An integer K(1<=K<=2000) representing the total number of people; 2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input

2 2 20 25 40 1 8

Sample Output

08:00:40 am 08:00:08 am

題目大意:一個人上班在售票機那裡賣電影票,他可以一次取出一張電影票來賣給別人,也可以一次取出兩張來賣給倆人,問這個人最早幾點下班(即所有買票人都買完票了)。給了你k個人取票所用時間,k-1組兩兩組合後取票所用時間。

解題思路:動態規劃,狀態轉移方程為dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]),即要麼第i個人單獨買,要麼第i個人跟第i-1個人一起買。(上班時間是早上八點)

程式碼如下:


#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
int a[2010];
int b[2010];
int dp[2010];
int main()
{
    int t;
    int x,y,c;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(dp,0,sizeof(dp));
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=2; i<=n; i++)
        {
            scanf("%d",&b[i]);
        }
        dp[1]=a[1];
        dp[2]=min(a[1]+a[2],b[2]);//前鍵
        for(int i=3; i<=n; i++)
        {
            dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
        }
        int ans=dp[n];
        x=8,y=c=0;                              //時間轉換
        y+=(ans/60);
        c=ans%60;
        x+=(y/60);
        y%=60;
        if(x>12||(x==12&&(y>0||c>0)))
            printf("%.2d:%.2d:%.2d pm\n",x,y,c);
        else
            printf("%.2d:%.2d:%.2d am\n",x,y,c);
    }
    return 0;
}