1. 程式人生 > >2823 Sliding Window【單調佇列優化dp && c++快讀】

2823 Sliding Window【單調佇列優化dp && c++快讀】

Sliding Window

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 72718 Accepted: 20659
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k

 numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:  The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7 
-3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n

 and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

<span style="color:#000000">8 3
1 3 -1 -3 5 3 6 7
</span>

Sample Output

<span style="color:#000000">-1 -3 -3 -3 3 3
3 3 5 5 6 7
</span>

Source

思路:

從區間[L,R]轉移到區間[L+1,R+1]時,我們可以利用之前的資訊。

求區間最小值時,我們可以維護一個單調遞增的佇列。我們可以用陣列模擬佇列,並開一個輔助陣列記錄佇列中相應元素的下標。

新增資料時,可以把佇列後面所有大於等於它的全部捨棄掉,把資料入隊。刪除資料時,只需要把隊首元素下標小於當前區間左邊界的刪除即可。

c++快速讀入:

cin.tie(0);
std::ios::sync_with_stdio(false);

程式碼:

#include <stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define MAXN 1000005
int n,k,a[MAXN],tmp[MAXN],que[MAXN],dpmin[MAXN],dpmax[MAXN];
void DPmin()
{
    int head=1,tail=0;
    for(int i=0; i<n; i++)
    {
        while(tmp[head]<i-k+1 && head<=tail) head++;
        while(head<=tail && que[tail]>=a[i]) tail--;
        que[++tail]=a[i];
        tmp[tail]=i;
        dpmin[i]=que[head];
    }
}
void DPmax()
{
    int head=1,tail=0;
    for(int i=0; i<n; i++)
    {
        while(tmp[head]<i-k+1 && head<=tail) head++;
        while(head<=tail && que[tail]<=a[i]) tail--;
        que[++tail]=a[i];
        tmp[tail]=i;
        dpmax[i]=que[head];
    }
}
int main()
{
    cin.tie(0);
    std::ios::sync_with_stdio(false);
    cin>>n>>k;
    for(int i=0; i<n; i++)
        cin>>a[i];
    DPmin();
    DPmax();
    for(int i=k-1; i<n; i++)
    {
        if(i>k-1) cout<<" ";
        cout<<dpmin[i];
    }
    cout<<"\n";
    for(int i=k-1; i<n; i++)
    {
        if(i>k-1) cout<<" ";
        cout<<dpmax[i];
    }
    cout<<"\n";
    return 0;
}