1. 程式人生 > >【POJ】3311Hie with the Pie

【POJ】3311Hie with the Pie

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9939 Accepted: 5360

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n

). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i
 to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

膜拜大佬!

題目大意:類似於TSP問題,只是每個點可以走多次,比經典TSP問題不同的是要先用弗洛伊的預處理一下兩兩之間的距離。求最短距離。

【狀態表示】dp[state][i]表示到達i點狀態為state的最短距離

【狀態轉移方程】dp[state][i] =min{dp[state][i],dp[state'][j]+dis[j][i]} dis[j][i]為j到i的最短距離

【DP邊界條件】dp[state][i] =dis[0][i]  state是隻經過i的狀態

程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 100000000
using namespace std;
int dis[12][12];
int dp[1<<11][12];
int n,ans,_min;
int main()
{
   //freopen("in.txt","r",stdin);
   while(scanf("%d",&n) && n)
   {
       for(int i = 0;i <= n;++i)
           for(int j = 0;j <= n;++j)
               scanf("%d",&dis[i][j]);
       for(int k = 0;k <= n;++k)
           for(int i = 0;i <= n;++i)
                for(int j = 0;j <=n;++j)
                    if(dis[i][k] + dis[k][j]< dis[i][j])
                        dis[i][j] = dis[i][k] +dis[k][j];

       for(int S = 0;S <= (1<<n)-1;++S)//列舉所有狀態,用位運算表示
           for(int i = 1;i <= n;++i)
           {
                if(S & (1<<(i-1)))//狀態S中已經過城市i
                {
                    if(S ==(1<<(i-1)))   dp[S][i] =dis[0][i];//狀態S只經過城市I,最優解自然是從0出發到i的dis,這也是DP的邊界
                    else//如果S有經過多個城市
                    {
                        dp[S][i] = INF;
                        for(int j = 1;j <=n;++j)
                        {
                            if(S &(1<<(j-1)) && j != i)//列舉不是城市I的其他城市
                                dp[S][i] =min(dp[S^(1<<(i-1))][j] + dis[j][i],dp[S][i]);
                            //在沒經過城市I的狀態中,尋找合適的中間點J使得距離更短
                        }
                    }
                }
            }
       ans = dp[(1<<n)-1][1] + dis[1][0];
       for(int i = 2;i <= n;++i)
           if(dp[(1<<n)-1][i] + dis[i][0] < ans)
                ans = dp[(1<<n)-1][i] +dis[i][0];
       printf("%d\n",ans);
   }
   return 0;
}