1. 程式人生 > >POJ-1797 Heavy Transportation(最短路變形)

POJ-1797 Heavy Transportation(最短路變形)

                                                Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 50055 Accepted: 12925

Description

Background  Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.  Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.  

Problem 

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

傳送:

題意:

給你n個點,m條路,每條路上都有一個最大承載量,需要找一條路徑,使得這條路徑有最大承載量。一條路的最大承載量就是這些路中最小的承載量。輸出最大路中的最小承載量。

思路:

上題求最小路徑中所有路的最大值。這題求的是最大路徑中所有路的最小值。

直接改下Dijkstra模板。注意map[][]初始值應為0,而不是INF。

程式碼:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring> 
#include<cmath>

using namespace std;
const int MAXN = 1005;
const int INF = 99999990;
int map[MAXN][MAXN];
bool vis[MAXN];
int dis[MAXN];

void Dijkstra(int n)
{
	for(int i = 1; i <= n; i++) {
		dis[i] = map[1][i];
		vis[i] = false;
	} 
	dis[1] = 0;
	for(int j = 1; j <= n; j++) {
		int k = -1;
		int Max = -1;
		for(int i = 1; i <= n; i++) {
			if(!vis[i] && dis[i] > Max) {
				Max = dis[i];
				k = i;
			}
		}
		if( k == -1 ) break;
		vis[k] = true;
		for(int i = 1; i <= n; i++ ) {
			if(!vis[i]) {
				int Minn = min(dis[k], map[k][i]);
				if(dis[i] < Minn) {
					dis[i] = Minn;	
				}
				
			}
		}
	}
}

int main()
{
	int t;
	cin >> t;
	int Case = 1;
	while(t--) {
		int n, m;
		cin >> n >> m;

		memset(map, 0, sizeof(map));  //不能為INF,因為求的是最大值中的最小值 
		for(int i = 1; i <= m; i++) {
			int from, to, weight;
			cin >> from >> to >> weight;
			map[from][to] = map[to][from] = weight;
		}
		
		Dijkstra(n);
		printf("Scenario #%d:\n", Case++);
		printf("%d\n\n", dis[n]);
	}
	
	return 0;
}