1. 程式人生 > >Silver Cow Party (定點X為起點和終點的最長距離)

Silver Cow Party (定點X為起點和終點的最長距離)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X  Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai

 to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

題意:牛到X開爬梯,問,哪個牛從起點到X點和從X點到起點的和距離最長

思路:Dijkstra求出以X為起點和以X為終點的距離,再找兩者的和最大者

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
using namespace std;
const int inf =0x3f3f3f;
int mp[1010][1010];
int vis[1010];
int g[1010],b[1010];
int x,n,m;
void dij()
{
    int mi,v;
    for(int i=1; i<=n; i++)
    {
        b[i]=mp[x][i];
        g[i]=mp[i][x];
    }
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
    {
        mi=inf;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&b[j]<mi)
            {
                mi=b[j];
                v=j;
            }
        }
        vis[v]=1;
        for(int j=1; j<=n; j++)
        {
            if(b[j]>b[v]+mp[v][j])
                b[j]=b[v]+mp[v][j];
        }

    }
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
    {
        mi=inf;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&g[j]<mi)
            {
                mi=g[j];
                v=j;
            }
        }
        vis[v]=1;
        for(int j=1; j<=n; j++)
        {
            if(g[j]>g[v]+mp[j][v])
                g[j]=g[v]+mp[j][v];
        }
    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&x);
    for(int i=1; i<=n; i++)
        for(int j=1; j<=n; j++)
        {
            if(i==j)
                mp[i][j]=0;
            else mp[i][j]=inf;
        }
    for(int i=1; i<=m; i++)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(mp[a][b]>c)
            mp[a][b]=c;
    }
    dij();
    int ans=0;
    for(int i=1; i<=n; i++)
    {
        ans=max(ans,g[i]+b[i]);
    }
    printf("%d\n",ans);
    return 0;
}