1. 程式人生 > >拓展歐幾里得——egcd poj2142

拓展歐幾里得——egcd poj2142

                                              The Balance

 Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 

  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.


No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

第一次寫拓展歐幾里德的題,花了很久理解這個演算法,搞清楚了這些egcd返回值就是gcd( a , b );函式裡面算出來的x,y是隨機傳參的。算完了得到的x,y再*d/ gcd 才能得到初始的x,y.

這個題題意:求出滿足a*x+b*y=d 的最小的 | x | + | y |;

先把x0,y0,算出來;

由x,y 的一般式     

x=x0+b/d*t

y=y0-a/d*t 可以先假設 a>b,不滿足就swap(a,b)

然後得到這麼個B玩兒            |x|+|y|==|x0+b/d*t|+|y0-a/d*t|;

然後xjb猜當y0=a/d*t的時候 |x|+|y|可能最小;

最後在這個t的周圍試幾個數就行了……

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <cmath>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
int a,b,d;

int egcd(int a,int b,int &x,int &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    int gcd=egcd(b,a%b,y,x);
    y-=a/b*x;
    return gcd;
}
int main()
{
    while(scanf("%d%d%d",&a,&b,&d)!=EOF,a||b||d)
    {
        int x,y;
        int flag=0;
        if(a<b) swap(a,b),flag=1;
        int gcd=egcd(a,b,x,y);
        x=x*(d/gcd);
        y=y*(d/gcd);//一組x y 的 解
        //cout<<x<<' '<<y<<endl;
        int t=y*gcd/a;
        int ans=INF;
        int minx,miny;
        for(int i=t-1;i<=t+1;++i)
        {
            int hh=fabs(y-(a/gcd)*i)+fabs(x+(b/gcd)*i);
            if(ans>hh)
            {
                ans=hh;

                minx=fabs(x+(b/gcd)*i);
                miny=fabs(y-(a/gcd)*i);
                //cout<<minx<<' '<<miny<<endl;
            }
        }
        if(flag)  printf("%d %d\n",miny,minx);
        else      printf("%d %d\n",minx,miny);
    }
}