1. 程式人生 > >1069 The Black Hole of Numbers(字串處理)

1069 The Black Hole of Numbers(字串處理)

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089 9810 - 0189 = 9621 9621 - 1269 = 8352 8532 - 2358 = 6174 7641 - 1467 = 6174 … … Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4

​​ ).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

分析

此題考查字串的處理,本題不難,主要要掌握c語言中常用的字串函式。 注:strcpy函式 函式宣告 char* strcpy( char* dest, const char* src )

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int main() {
   int n;
   scanf("%d",&n);
   char s[5];
   sprintf(s,"%04d",n);
   sort(s,s+4,greater<char>());
   if(s[0]==s[3]) printf("%s - %s = 0000\n",s,s);
   else {
   	while(1) {
   		char s1[5];
   		strcpy(s1,s);
   		sort(s,s+4);
   		int a1,a2;
   		sscanf(s1,"%d",&a1);
   		sscanf(s,"%d",&a2);
   		int ans=a1-a2;
   		printf("%04d - %04d = %04d\n",a1,a2,ans);
   		if(ans==6174) break;
   		sprintf(s,"%04d",ans) ;
   		sort(s,s+4,greater<char>());
   	}
   }
   return 0;
}