1. 程式人生 > >1070 Mooncake(貪心演算法)

1070 Mooncake(貪心演算法)

1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

分析

本題考查貪心演算法,難度不大,但是關於市場最大需求量D和貨物供應量amount的資料型別選型涉及到測試點2(從0開始)是否能通過。題面表述D和N時指出兩個 正整數,因此D的型別選為int,對於amount的型別,題面沒有明說,這個需要我們仔細觀察和揣摩 ( 隱藏的失分點),依據生活經驗,amount的單位是thousand ton,amount存在小數的可能,所以講amount的型別定為double.

#include<iostream> 
#include <vector>
#include <algorithm>
using namespace std;
struct node{
	double amount,prices;
};
bool cmp(node a,node b){
	return a.prices/a.amount>b.prices/b.amount;
}
int main(){
	int n,d;
	cin>>n>>d;
	vector<node> v(n);
	for(int i=0;i<n;i++) cin>>v[i].amount;
	for(int i=0;i<n;i++) cin>>v[i].prices;
	sort(v.begin(),v.end(),cmp);
	double profit=0.0;
	int k=0;
	while(d>0 && k<n){
		if(d>v[k].amount){
			profit+=v[k].prices;
			d-=v[k].amount;
			k++;
		}else{
			profit+=v[k].prices*d/v[k].amount;
			d=0;
		}
	}
	printf("%.2lf\n",profit);
	return 0;
}