1. 程式人生 > >PAT甲級 1072 Gas Station (30 分)Dijkstra

PAT甲級 1072 Gas Station (30 分)Dijkstra

1072 Gas Station (30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M(≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G

1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution

.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

題目大意:從m個加油站裡面選取1個站點,讓他離居民區的最近的人最遠,並且沒有超出服務範圍ds之內。如果有很多個最遠的加油站,輸出距離所有居民區距離平均值最小的那個。如果平均值還是一樣,就輸出按照順序排列加油站編號最小的那個

注意:a 和 b 的賦值,例如a可以取值100,所以要用stoi轉換

#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;

const int N = 1020,inf = 99999999;
int e[N][N],dsp[N];
bool vst[N];

int main(){
	fill(e[0],e[0]+N*N,inf);
	fill(dsp,dsp+N,inf);
	fill(vst,vst+N,false);
	
	int n,m,k,ds;
	cin>>n>>m>>k>>ds;
	
	int a,b;
	for(int i=0;i<k;i++){
		int dst;
		string p1,p2;
		cin>>p1>>p2>>dst;
		if(p1[0] == 'G')
		{
			a = n + stoi(p1.substr(1));
		}else
			a = stoi(p1);//不能用a = p1[0] - '0',例如a可能是100 
		
		if(p2[0] == 'G')
		{
			b = n + stoi(p2.substr(1));
		}else
			b = stoi(p2);
		e[a][b] = e[b][a] = dst;
	}
	int ansid = -1;
	float ansdis = -1,ansaver = -1;
	for(int index = n+1;index <= n+m;index++){
		fill(dsp,dsp+N,inf);
		fill(vst,vst+N,false);
		
		float tempdis = inf,tempaver = 0;
		
		dsp[index] = 0;
		for(int i = 1;i<=n+m;i++){
			int u = -1,minn = inf;
			for(int j = 1;j<=n+m;j++){
				if(vst[j] == false && dsp[j] < minn){
					u = j;
					minn = dsp[j];
				}
			}
			
			if(u == -1)
				break;
			vst[u] = true;
			for(int v = 1;v<=n+m;v++){
				if(vst[v] == false && dsp[v] > dsp[u] + e[u][v]){
					dsp[v] = dsp[u] + e[u][v];
				}
			}	
		}
		
		for(int i=1;i<=n;i++)
		{
			if(dsp[i] > ds){
				tempdis = -1;
				break;
			}
			if(dsp[i] < tempdis){
				tempdis = dsp[i];
			}
			tempaver += dsp[i];
		}
		if(tempdis == -1)
			continue;
		tempaver = tempaver / n;
		if(tempdis > ansdis){
			ansid = index;
			ansdis = tempdis;
			ansaver = tempaver;
		}
		else if(tempdis == ansdis && tempaver < ansaver){
			ansid = index;
			ansaver = tempaver;
		} 
	}
	
	if(ansid == -1)
		printf("No Solution");
	else
		printf("G%d\n%.1f %.1f",ansid-n,ansdis,ansaver); 
	
	return 0;
}