1. 程式人生 > >Invitation Cards (spfa從源點(1)到其他點來回的最短路之和)

Invitation Cards (spfa從源點(1)到其他點來回的最短路之和)

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.  The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.  All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

題意:計算從源點到其他點來回的最短路之和

思路:資料較大,spfa正反各跑一次,累計源點到其他點之間的最短路

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <queue>
const int =INF 0x3f3f3f3f;
using namespace std;
const int N=1212121;
int a[N][3];//儲存輸入的兩點及之間的距離,由於題目需要返回去,所以要建立兩遍,倒向建立
struct node
{
    int to, w, next;//要去的節點序號,權值,前一個以其為起點的邊
} t[N];
int dis[N];//距離
int n, m;
bool v[N];//是否在佇列裡,而不是是否訪問過
int top;
int head[N];//前一個節點序號
void Initial()//初始化
{
    memset(v, false, sizeof(v));
    memset(head, -1, sizeof(head));
    for(int i=0; i<=n; i++)
        dis[i] = INF;
}
void addedge(int a, int b, int c)//加邊
{
    t[top].to = b;
    t[top].w = c;
    t[top].next = head[a];
    head[a] = top++;
}
long long int spfa()
{
    queue<int>q;
    q.push(1);
    v[1] = true;
    dis[1] = 0;
    long long int ans = 0;
    while(!q.empty())
    {
        int k = q.front();
        q.pop();
        v[k] = false;
        for(int i=head[k]; i!=-1; i=t[i].next)
        {
            int to = t[i].to;
            int w = t[i].w;
            if(dis[to]>dis[k]+w)
            {
                dis[to]=dis[k]+w;//更新
                if(v[to]==false)//不在佇列裡,則加入
                {
                    q.push(to);
                    v[to] = true;
                }
            }
        }
    }
    for(int i=1; i<=n; i++) //求和
        ans += dis[i];
    return ans;
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d %d", &n, &m);
        top = 0;
        Initial();
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d", &a[i][0], &a[i][1], &a[i][2]);
            addedge(a[i][0], a[i][1], a[i][2]);
        }
        long long int sum = spfa();
        top = 0;
        Initial();
        for(int i=0; i<m; i++) //反向建立
        {
            addedge(a[i][1], a[i][0], a[i][2]);
        }
        sum += spfa();//兩次之和
        cout<<sum<<endl;
    }
    return 0;
}

無憂望月

#include<algorithm>
#include<stack>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<string>
#include<map>
#include<iostream>
using namespace std;

const int maxn = 1000005;
const int oo = 0x3fffffff;

struct BusStation
{
    int u, v, nextBus;
    long long pay;
}ege[maxn], data[maxn];

int head[maxn];
long long dis[maxn];
bool use[maxn];

void Add(int u, int v, long long w, int k)
{
    data[k].u = u;
    data[k].v = v;
    data[k].pay = w;
    data[k].nextBus = head[u];
    head[u] = k;
}

long long spfa(int N)
{
    stack<int> Q;
    Q.push(1);
    use[1] = true;

    for(int i=1; i<=N; i++)
        dis[i] = oo;
    dis[1] = 0;

    while(Q.size())
    {
        int i = Q.top();Q.pop();
        use[i] = false;

        for(int j=head[i]; j != 0; j = data[j].nextBus)
        {
            int u = data[j].u, v = data[j].v;
            int pay = data[j].pay;

            if(dis[u]+pay < dis[v])
            {
                dis[v] = dis[u] + pay;

                if(use[v] == false)
                {
                    Q.push(v);
                    use[v] = true;
                }
            }
        }
    }

    long long sum=0;

    for(int i=1; i<=N; i++)
        sum += dis[i];

    return sum;
}

int main()
{
    int T;

    scanf("%d", &T);

    while(T--)
    {
        int i, N, M;

        scanf("%d%d", &N, &M);

        memset(head, 0, sizeof(head));
        for(i=1; i<=M; i++)
        {
            scanf("%d%d%lld", &ege[i].u, &ege[i].v, &ege[i].pay);
            Add(ege[i].u, ege[i].v, ege[i].pay, i);
        }

        long long sumPay;

        sumPay =  spfa(N);

        memset(head, 0, sizeof(head));
        for(i=1; i<=M; i++)
            Add(ege[i].v, ege[i].u, ege[i].pay, i);

        sumPay += spfa(N);

        printf("%lld\n", sumPay);
    }

    return 0;}