1. 程式人生 > >Anniversary party(HDU-1520)

Anniversary party(HDU-1520)

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input 

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:  L K  It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line  0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output

5

————————————————————————————————————————————————————

跟洛谷 沒有上司的舞會 是一個題,題意及思路:點選這裡

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 10001
#define MOD 10007
#define E 1e-6
#define LL long long
using namespace std;
vector<int> son[N];
int happy[N];
bool vis[N];
int f[N][2];
void treeDP(int x){
    f[x][0]=0;//如果沒去,為0
    f[x][1]=happy[x];//如果去了,為相應happy值
 
    for(int i=0;i<son[x].size();i++){//列舉x的所有孩子
        int y=son[x][i];
        treeDP(y);//遞迴
        f[x][0]+=max(f[y][0],f[y][1]);//父親沒去的值為孩子去或不去的最大值
        f[x][1]+=f[y][0];//父親去了的值為孩子不去的值
    }
}
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>happy[i];
    for(int i=1;i<=n-1;i++){
        int x,y;
        cin>>x>>y;
        son[y].push_back(x);//儲存職員關係
        vis[x]=true;//標記
    }
 
    int root;
    for(int i=1;i<=n;i++){  //尋找根節點
        if(!vis[i]){
            root=i;
            break;
        }
    }
 
    treeDP(root);//對根節點進行dp
    int res=max(f[root][0],f[root][1]);//比較根節點去或不去
    cout<<res<<endl;
 
	return 0;
}